45 users online (0 members and 45 guests)  


  Results 1 to 2 of 2

Related

  1. Problem with excel file writing using PERL    Forum: CGI Perl Forum
    Replies: 0
  2. Replies: 0
  3. perl script to limit access to website    Forum: CGI Perl Forum
    Replies: 3
  4. web form data import to ms access db    Forum: PHP Forum
    Replies: 2
  5. Replies: 2
  1. #1
    abhelp's Avatar
    New User

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    1

    data files location and permission to access from perl cgi script for writing

    Hello all

    What I have is a bunch of csv files with different version numbers. I have written a perl program which sorts these files, reads/writes to these files and then creates an HTML file for displaying this data content. Now I want to convert this perl program to a CGI script with an HTML post form input which lets the user enter version numbers of these files and how many files to use for sorting. Based on this information the perl program finds these files from a directory listing,reads and writes data and sorts the content (also creates temporary files along with modifying existing csv files) and then creates a html file for display. Now When I tried to write any data file from perl cgi program in /var/www/html directory I get permission denied. I also created another temp directory with chmod 777 and tried writing to it from my cgi script but still got permission denied error. Which directory should I use to store these csv data files so I can write to these files from the CGI program.What is the best way to do this. Or should I run my perl program ( for sorting, writing temp files etc) from this CGI script and then CGI script accepts the HTML form entries and passes them as command line arguments to my perl program. How would I do this? I am using Linux with apache.

    Thanks

  2. #2
    xmassey's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Apr 2007
    Posts
    100

    Re: data files location and permission to access from perl cgi script for writing

    Hello,

    Could you provide a copy of your perl script. Otherwise, you may be able to solve your issue by checking http://www.slingcode.com/suexec.php.

    Chris