56 users online (0 members and 56 guests)  


  Results 1 to 14 of 14
  1. #1
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7

    Question I can't see some of my own CSS!

    I hope you guys can help me out with this.

    I'm using a stylesheet with my pages. I can see all the a:link and those CSS, I used to be able to see my own scrollbar codes and now they won't work at all! The weird thing is that I've always used the SAME codes and I can't see others codes. If I try to copy & paste their codes, all of sudden, I can't see it anymore, while I can still view it on their pages.

    This is really confusing, I can't see what could it be. As I said, I'm pretty sure it can't be my code because if I copy and paste it from someone else's code that I can actually view, why wouldn't it work for me?

    Is it possible that this would be something a lil' picky like SSI? Although I used to be able to see my CSS from my hardrive, now even from the server I can't see it.

    I also tried putting the scrollbar code on page with no stylesheet attached, thinking there might be a conflict, and it still won't work. I looked at some codes that were posted here and that's exactly the one I use...

    Anyhoo... any ideas will definitely help!

    Thanks

    IpharraTech.

  2. #2
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Hi, welcome to the forums.

    I assume you are using Internet Explorer. Have you checked the bugs on http://msdn.microsoft.com
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  3. #3
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    Hey thanks for the welcome

    No, I haven't... I'm trying to find something now about it right now.

    Any browser to recommend? I used to use Opera 7 too, very fast, but it also had problems with CSS...

    IpharraTech.

  4. #4
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Mozilla Firebird is, well, fabulous!
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  5. #5
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    Hmm... alright... I found what was wrong with some of them, my cache memory was full and it was mixing up stuff *anyway*.

    Now... is it possible to change the scrollbar colors of a iframe? I tried for 3 hours, searching EVERYWHERE for ways to do it and it won't work.

    Let me know if someone found a magical way.

    I even tried with Mozilla and it doesn't work. Pretty discouragin'.

    Thanks

    IpharraTech.

  6. #6
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Mozilla doesn't support coloured scrollbars, because IE basically made them up so they are not part of the standards.

    The trick to colouring iframe scrollbars is to add the scrollbar css to the document being called inside the iframe. In other words, put the code in the document contained in the iframe src="blah.html"

    Add it to the Body just as you would for a normal document.
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  7. #7
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    Already tried it and it won't work...

    I use stylesheets and it will work with layers, but not with iframes.

    IpharraTech.

  8. #8
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Hi,

    Post a link to your code and I can try and see why its not working.
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  9. #9
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    Here you go...

    I know the link to my stylesheet works because everything excepted my scrollbar colors shows...

    body {
    font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
    font-size: 10px;
    font-style: normal;
    color: #000000;
    text-decoration: none;
    background-attachment: fixed;
    background-color: #FFFFFF;
    background-repeat: no-repeat;
    cursor: crosshair;
    SCROLLBAR-FACE-COLOR: #FFFFFF;
    SCROLLBAR-HIGHLIGHT-COLOR: #CCCCCC;
    SCROLLBAR-SHADOW-COLOR: #CCCCCC;
    SCROLLBAR-3DLIGHT-COLOR: #FFFFFF;
    SCROLLBAR-ARROW-COLOR: #666666;
    SCROLLBAR-TRACK-COLOR: #FFFFFF;
    SCROLLBAR-DARKSHADOW-COLOR: #FFFFFF;
    margin: 0px;
    }
    a:link {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    color: #FF5B0B;
    text-decoration: none;
    font-weight: bold;
    }
    a:visited {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    color: #FF5B0B;
    text-decoration: none;
    font-weight: bold;
    }
    a:active {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    color: #FF5B0B;
    text-decoration: none;
    font-weight: bold;
    }
    a:hover {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    color: #871903;
    text-decoration: underline;
    cursor: crosshair;
    font-weight: bold;
    }

    td {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    color: #000000;
    text-align: left;
    }

    li {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    text-align: left;
    }
    img {
    border: 0px;
    }

    IpharraTech.

  10. #10
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    I made a page inside an iframe that just looked like this -
    Code:
    <link rel="stylesheet" href="test.css" type="text/css">
    <br /><br /><br /><br /><br /><br />
    <br /><br /><br /><br /><br /><br />
    <br /><br /><br /><br /><br /><br />
    
    <br /><br /><br /><br /><br /><br />
    <br /><br /><br /><br /><br /><br />
    <br /><br /><br /><br />
    and my test.css was exactly what you posted above. For me, this works in IE 6.0. (White scrollbar in the iframe).

    Whats different about yours? If cant spot it, post ALL your code.
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  11. #11
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    That's all my code.

    I noticed that on some other websites that have iframes I can't see it either...

    Unless you want to see my index.htm file... I didn't use the style sheet in this section because I didn't want the same styles... anyhoo, I don't see how it could conflict because I tried all this before adding separate styles to this page.

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>MV Canadian Warmbloods</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    body {
    font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
    font-size: 10px;
    color: #FFFFFF;
    text-decoration: none;
    text-align: left;
    vertical-align: top;
    cursor: crosshair;
    background-color: #00005D;
    margin: 0px;

    }
    td {
    font-family: Verdana, Geneva, Arial, helvetica, sans-serif;
    font-size: 10px;
    text-align: left;
    font-weight: normal;
    }
    a:link {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    font-weight: bold;
    color: #FFFFFF;
    text-decoration: underline;
    cursor: crosshair;
    }
    a:visited {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    font-weight: bold;
    color: #FFFFFF;
    text-decoration: underline;
    cursor: crosshair;
    }
    a:active {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    font-weight: bold;
    color: #FFFFFF;
    text-decoration: underline;
    cursor: crosshair;
    }

    a:hover {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    font-weight: bold;
    color: #FF0000;
    text-decoration: underline;
    cursor: crosshair;
    }
    li {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 10px;
    text-align: left;
    }
    -->
    </style>
    </head>
    <p align="center">
    <img src="images/logo.gif"><br>
    <a href="main.htm" target="main">Welcome</a> - <a href="services.htm" target="main">Services</a> - <a href="sales.htm" target="main">Sales</a> - <a href="horses.htm" target="main">Horses</a> - <a href="contact.htm" target="main">Contact</a><br>
    <br>
    <table width="642" height="312" border="1" cellpadding="0" cellspacing="0" bordercolor="#00005D" align="center">
    <tr>
    <td bordercolor="#000380">
    <iframe border="0" name="main" src="main.htm" frameBorder="0" width="640" height="310" align="center" scrolling="yes" overflow="hidden"></iframe>
    </td>
    </tr>
    </table>
    <br>
    <p align="center">This is all part of a SIM game called Hay! Land. <a href="disclaimer.htm" target="main">Disclaimer </a></p>

    <body>
    </body>
    </html>

    and I've posted ALL the content of my stylesheet in my previous post.

    My boyfriend is an IT specialist but he's not familiar at all with CSS and he doesn't seem to think it could be something with IE (neider do I now since you told me you can see it), but I'm starting to think that perhaps when we formatted my PC a couple of weeks ago IE didn't install properly... I'll look into that too. Meanwhile, you guys can take a look at my code to ensure that it isn't anything with my code.

    Thanks!!

    IpharraTech.

  12. #12
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Hi,

    wha version of IE are you using? (Help->About Internet Explorer)
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?

  13. #13
    ipharratech's Avatar
    New User

    Status
    Offline
    Join Date
    Jan 2004
    Posts
    7
    I'm using 6.0

    IpharraTech.

  14. #14
    QuietDean's Avatar
    Administrator

    Status
    Offline
    Join Date
    Oct 2000
    Location
    Bournemouth, UK
    Posts
    2,662
    Using your source above, it sttill works for me.

    This leaves the source for main.htm as the only thing I haven't got, hence in theory the only thing different.

    Its possible there is something wrong with your browser/pc, too. Try updating at www.windowsupdate.com

    In the meantime, could you post the code for main.htm
    If one of our members helps you, please click the icon to add to their reputation!
    No support via email or private message - use the forums!
    Before you ask, have you Searched?



Tags for this Thread