39 users online (0 members and 39 guests)  


  Results 1 to 5 of 5

Related

  1. Replies: 0
  2. Error Installing    Forum: CGI Perl Forum
    Replies: 1
  3. installing a forum    Forum: Barter/Trade
    Replies: 2
  4. installing a forum    Forum: PHP Forum
    Replies: 0
  5. installing a forum    Forum: PHP Forum
    Replies: 2
  1. #1
    Nugget's Avatar
    New User

    Status
    Offline
    Join Date
    May 2006
    Posts
    3

    Installing gd-lib

    Hi there!

    I'm trying to learn Perl and at this stage I'm supposed to install GD.pm and gd-lib on my win2k. My question is if there is anyone out there who knows how to compile gd-lib, maybe from MS Visual C\C++. Maybe it's possible to compile it from Perl itself? I've looked on the Internet but haven't found any installation guide for beginners.

    I use "WindowsDLL.zip" from http://www.boutell.com/gd/ . I've tried to read the manual and according to it, the dll-file should go in the system folder, so i put it in my WINNT-folder on C:, but when I testrun my file bildttest.cgi with Perl in the commandline I get the following error message:

    Can't locate GD\Image.pm in @INC (@INC contains: C:/Perl/lib C:/Perl/site/lib) at C:/Perl/lib/GD.pm line 14
    BEGIN failed--compilation aborted at C:/Perl/lib/GD.pm line 14.
    Compilation failed in require at bildttest.cgi line 3.
    BEGIN failed--compilation aborted at bildttest.cgi line 3.

    This makes me think that the gd-lib isn't installed correctly. Also the "WindowsDLL.zip" contains programs on jpg, png, and stuff I don't have a clue on how to use.

    Greatful for all replies

    Nugget

  2. #2
    uthus's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Ft Hood
    Posts
    75

    Re: Installing gd-lib

    From the website: WARNING: AS OF GD 2.0.24, THE http://www.boutell.com/gd/# WINDOWS DLL HAS BEEN CHANGED IN A WAY THAT REQUIRES RECOMPILING EXISTING APPLICATIONS...

    This means to me that your app needs to be recompiled, not the lib.

    And what does line 14 in GD.pm say? I'm not using the gd lib for anything currently.

  3. #3
    Nugget's Avatar
    New User

    Status
    Offline
    Join Date
    May 2006
    Posts
    3

    Re: Installing gd-lib

    First, about the website, I'm using gd-lib2.32, so I'm not sure that problem concerns my version.

    I also looked up line 14 in GD.pm and this is what it says:

    use GD::Image;

    Line 3 in bildttest.cgi says: use GD;

    Also, my initial problem is how to install the lib in the first place. Does it have to be done with compiling the whole thing in C\C++ or can it be compiled in Perl itself. In either case how do you do that.? Cause according to the manual the dll should be put in a system folder (like WINNT), but that doesn't seem to cut it. (See above).

    Best regards
    Nugget

  4. #4
    uthus's Avatar
    Senior Member

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Ft Hood
    Posts
    75

    Re: Installing gd-lib

    line 3 in bildtest referst to the whole GD package. Line 14 refers to a module in the package. other than that, i don't know. i'm a linux user and anytime i need a package i just run from the command prompt (dos prompt) something like this:

    cpan install GD

    it would find the package, compile it, if anything is missing it will tell me and then locate what it needs to complete the process.

    i don't have any ideas.

    sorry,

    u

  5. #5
    Nugget's Avatar
    New User

    Status
    Offline
    Join Date
    May 2006
    Posts
    3

    Re: Installing gd-lib

    I tried writing cpan install GD at the dosprompt. It immidiately started to install all sorts of things, but it ended in failure just the same. I got lots of error messages, among the last ones was :

    Test returned status 2 (wstat 512, 0x200)
    FAILED--2 test scripts could be run, alas--no output ever seen
    NMAKE : fatal error U1077: 'C:\Perl\bin\perl.exe : returncode '0x2'
    Stop
    nmake test -- NOT OK
    Running make install
    nmake test had retuned bad status, won't install without force
    GD is up to date.


    Also my problem is with gd-lib not so much GD.pm. As I've understood it you have to install gd-lib first before you attempt an install of GD.pm

    When i try to run bildttest.cgi I still get the same results as in my first post


    Nugget



Tags for this Thread