35 users online (0 members and 35 guests)  


  Results 1 to 3 of 3
  1. #1
    king_cucaracha's Avatar
    New User

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    2

    Peek a Boo? Bug???

    Hello I'm trying to apply a design on a website using CSS, I'm being attacked by something that I think, it's the Peekaboo bug (this rendering problem happens only on IE6, the page renders well on Firefox and Opera).

    The site that I'm working on, is based on the following CSS template www.getcsstemplates.com/zipped/no20.zip

    I found that when make a hover on the top menu, the bottom of the page disappears, and when i make hover on the right column menu, it appears again.

    At first I tought that it was 'cause some mods that I made to the template, but then realized that it was on the original template too.

    I think that the behavior is the classic Peekaboo bug, but I've tried several cures for it (position relatives, fixed heights, even the hollyhack) across the whole CSS template and can not get rid of the bug.

    Can anyone please tell me what I'm doing Wrong? Where to apply the fixes for the peekaboo? is it something different than it?

    Thanks a lot, I've spent several days on this and can't figure it out, I'm new to CSS, and my deadline is coming for this. I can not tell the clients that all their users must change to a real browser (Firefox)

  2. #2
    vinyl-junkie's Avatar
    Moderator

    Status
    Offline
    Join Date
    Sep 2005
    Posts
    721

    Re: Peek a Boo? Bug???

    Have you made sure your page validates? Many times, doing this will clear up whatever problem you're experiencing. That's what I did when I had a similar problem, fixed my invalid page code, and the problem cleared up.
    Music Around The World - Collecting tips, trade
    and want lists, album reviews, & more

  3. #3
    king_cucaracha's Avatar
    New User

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    2

    Re: Peek a Boo? Bug???

    I removed the "title" attribute on the <a> tag at the footer, and it validated perfectly, also the CSS file validated ok, but stil, it keeps dissapearing the and reappering the bottom of the #maintext div as described above.
    Thanks



Tags for this Thread